Zeige Ergebnis 1 bis 11 von 11
  1. #1
    Benutzerbild von pawlak
    Registriert seit
    Feb 2002
    Beiträge
    11.719
    Likes
    58
    Also hier mal nen paar Probleme, die ich grad hab:

    aufm fileserver geht kein su. Meld mich normal als benutzer an, will su'en, gib das Passwort ein, und es kommt nur:

    su: Permission denied
    Sorry.

    Was geht da schief, wo muss ich da was einstellen? Das Passwort stimmt 100%.

    Dann noch eine Frage: wie kann ich einstellen, dass sich root nicht mehr einloggen kann? Also nur noch über su (wenn das dann mal funktioniert, davor sicher nicht ). muss ich in /etc/passwd nur /bin/false bei root eintragen, oder is das kompletter mist?

    Am Desktop PC nen andres Problem:

    nachm booten soll kdm gestartet werden (entrance taugt mir nimmer, kdm is schon nett), allerdings tut sich da teilweise nix mehr. Alle paar Systemstarts geht es mal, ansonsten muss ich mich erst einloggen und dann kdm starten. Es lief mal, wüsste nicht, dass ich groß was geändert hab, eventuell nvidia treiber aktualisiert, aber die funktioniern ja. Ach ja: KDE 3.3 wird genutzt.

    So: Emerge sync bringt ne schöne Meldung, also beim updaten ganz am ende. runtergeladen wurde schon alles, dann kommt unzählig viele Zeilen:

    has_version() in global scope: x11-themes/qtpixmap-0.28 ...done!

    damit dauert das "emerge sync" ungefähr 5 mal so lang wie normal. Es funktiniert allerdings.

    Danke schonmal für eure mühe
    Original geschrieben von pagenez
    ach und pawlak?
    du verhurrtes stück einer dreckwurst, halt doch bitte dein maul, ja? wer absolut kein real-life hat, einer wie du, der absolut nichts zu tun hat, als seine scheiße im irc auf andere abzulassen, sollte sich seinen daumen in das arschloch schieben, die augen schließen und dabei an *****n denken.
    alles klar?
    gut!


  2. #2
    Benutzerbild von stingray2
    Registriert seit
    Okt 2001
    Ort
    Darmstadt
    Beiträge
    5.015
    Likes
    0
    @root-direkt-login verbieten: in der datei /etc/securetty stehen die terminals drin an denen sich root einloggen darf.

  3. #3
    itaris
    Gast
    > Was geht da schief, wo muss ich da was einstellen?
    > Das Passwort stimmt 100%.

    Den User, der su ausführen will, in die Gruppe wheel stecken.

    > wie kann ich einstellen, dass sich root nicht mehr einloggen kann?

    €: Ok, die Antwort hier kann man vergessen, da root auch nicht mehr mit su reinkommt. Dann mußt du halt selbst in die Manpages gucken. <:

  4. #4
    Benutzerbild von pawlak
    Registriert seit
    Feb 2002
    Beiträge
    11.719
    Likes
    58
    @stingray: thx, aber geht über remote login, direkt am rechner anmelden is mir egal. hätte ich wohl sagen sollen

    @cirad: das mit wheel geht, sehr schön. Dass dein andrer Vorschlag nicht geht hab ich selbst mitbekommen Egal, habs gemerkt und wieder rückgängig gemacht, passt schon man pages werd ich mir mal zu gemüte führen

    danke für eure Antworten, es geht voran
    Original geschrieben von pagenez
    ach und pawlak?
    du verhurrtes stück einer dreckwurst, halt doch bitte dein maul, ja? wer absolut kein real-life hat, einer wie du, der absolut nichts zu tun hat, als seine scheiße im irc auf andere abzulassen, sollte sich seinen daumen in das arschloch schieben, die augen schließen und dabei an *****n denken.
    alles klar?
    gut!

  5. #5
    Zaphod|
    Gast
    Original erstellt von pawlak

    So: Emerge sync bringt ne schöne Meldung, also beim updaten ganz am ende. runtergeladen wurde schon alles, dann kommt unzählig viele Zeilen:

    has_version() in global scope: x11-themes/qtpixmap-0.28 ...done!

    damit dauert das "emerge sync" ungefähr 5 mal so lang wie normal. Es funktiniert allerdings.

    Schon mit 'emerge regen' probiert?

  6. #6
    Benutzerbild von stingray2
    Registriert seit
    Okt 2001
    Ort
    Darmstadt
    Beiträge
    5.015
    Likes
    0
    Original erstellt von pawlak
    @stingray: thx, aber geht über remote login, direkt am rechner anmelden is mir egal. hätte ich wohl sagen sollen
    erm, aja, sshd-config?

  7. #7
    Benutzerbild von pawlak
    Registriert seit
    Feb 2002
    Beiträge
    11.719
    Likes
    58
    @stingray: gnah, wie dumm von mir funktioniert... hätte ich auch selbst draufkommen können :/

    @Zaphod: bringt leider nix, gleiches Problem.

    also folgendes kommt:

    >>> Updating Portage cache...
    oggvorbis
    perl
    kde

    und noch einiges mehr. Ganz am ende dann

    has_version() in global scope: x11-themes/qtpixmap-0.28 ...
    done!

    wie zu beginn auch beschrieben!
    Ich frag mich halt, wo er die komische geschichte hernimmt, irgendwie seltsam :/
    Original geschrieben von pagenez
    ach und pawlak?
    du verhurrtes stück einer dreckwurst, halt doch bitte dein maul, ja? wer absolut kein real-life hat, einer wie du, der absolut nichts zu tun hat, als seine scheiße im irc auf andere abzulassen, sollte sich seinen daumen in das arschloch schieben, die augen schließen und dabei an *****n denken.
    alles klar?
    gut!

  8. #8
    tux-fan
    Gast
    So wie ich das sehe, bleibt nurnoch die KDE Problematik.
    Versuch mal vor KDE noch QT zu emergen. Vielleciht hilft das ja. Vorher aber unbedingt noch "opengl-update xfree", sonst gibt's möglicherweise bei ein paar Paketen noch Schwierigkeiten beim Übersetzen. NAch dem Compilieren natürlich wieder "opengl-update nvidia".
    KDE automatisch starten wird zum Einen in /etc/rc.conf eingestellt (DISPLAYMANAGER=kdm und XSESSION=kde), zum Andern noch "rc-update add xdm default" ausführen (hier xdm, nicht kdm)

    edit: möglicherweise isses ja auch der Effekt, wie mit qtpixmap-0.26 . Das Güne müßtest Du dann mal ans 0.28er ebuild anfügen.

    Code:
    # Copyright 1999-2003 Gentoo Technologies, Inc.
    # Distributed under the terms of the GNU General Public License v2
    # $Header: /home/cvsroot/gentoo-x86/x11-themes/qtpixmap/qtpixmap-0.26.ebuild,v 1.2 2003/09/06 07:28:56 msterret Exp $
    
    inherit gtk-engines2 eutils
    
    MY_PN="QtPixmap"
    
    IUSE=""
    DESCRIPTION="A modifed version of the original GTK pixmap engine which follows the KDE color scheme"
    HOMEPAGE="http://www.kde-look.org/content/show.php?content=7043"
    SRC_URI="http://www.kde-look.org/content/files/7043-${MY_PN}-${PV}.tar.gz"
    KEYWORDS="~x86 ~ppc ~sparc ~alpha"
    LICENSE="GPL-2"
    SLOT="2"
    
    DEPEND="${DEPEND}
            >=media-libs/imlib-1.8
            dev-util/pkgconfig
            =x11-libs/gtk+-1.2*"
    
    S=${WORKDIR}/${MY_PN}-${PV}
    [green]
    src_compile() {
        ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib || die
        emake || die[/green]
    }

  9. #9
    Benutzerbild von pawlak
    Registriert seit
    Feb 2002
    Beiträge
    11.719
    Likes
    58
    hab xfs ausm default runlevel raus, jetzt läufts scheinbar wieder... danke für die Hilfe!

    Jetzt is der pawlak wieder glücklich, ich ärger sarti nen bisschen im irc!

    edit: nein, das "emerge sync" problem besteht weiterhin, hätte ich ja fast vergessen
    Original geschrieben von pagenez
    ach und pawlak?
    du verhurrtes stück einer dreckwurst, halt doch bitte dein maul, ja? wer absolut kein real-life hat, einer wie du, der absolut nichts zu tun hat, als seine scheiße im irc auf andere abzulassen, sollte sich seinen daumen in das arschloch schieben, die augen schließen und dabei an *****n denken.
    alles klar?
    gut!

  10. #10
    Benutzerbild von pawlak
    Registriert seit
    Feb 2002
    Beiträge
    11.719
    Likes
    58
    ok, das emerge sync problem ist gelöst

    hab den inhalt von /usr/portage gelöscht. Nach 2 maligem emerge sync war der fehler verschwunden!
    Original geschrieben von pagenez
    ach und pawlak?
    du verhurrtes stück einer dreckwurst, halt doch bitte dein maul, ja? wer absolut kein real-life hat, einer wie du, der absolut nichts zu tun hat, als seine scheiße im irc auf andere abzulassen, sollte sich seinen daumen in das arschloch schieben, die augen schließen und dabei an *****n denken.
    alles klar?
    gut!

  11. #11
    Invad0r
    Gast
    das mit su hast du auch geschafft?
    ich hatte das problem auch. da musste ich mich der gruppe "wheel" adden, dann ging es

    greetz...

Forumregeln

  • Es ist dir nicht erlaubt, neue Themen zu verfassen.
  • Es ist dir nicht erlaubt, auf Beiträge zu antworten.
  • Es ist dir nicht erlaubt, Anhänge hochzuladen.
  • Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.
  •