Zeige Ergebnis 1 bis 7 von 7
  1. #1
    Benutzerbild von Baka
    Registriert seit
    Nov 2002
    Ort
    H zu dem i
    Beiträge
    3.846
    Likes
    0

    [Hjelp]ATI + SuSE + DAU = Linux putt

    Anlehnend an die Frage aus dem Announcement:

    Ich habe eine ATI Radeon Grafikkarte. Wie schalte ich die 3D-Beschleunigung ein?

    Vorweg, ich habe noch so gut wie keinerlei Erfahrung mit Linux. Eigentlich wollte ich es mir ja nur erstmal komplett einrichten, bevor ich mich umschaue. Hat aber nicht sollen sein.
    Zuerst wurde Suse 9.0 installiert, was prächtig funktionierte. 50.000 installierte Compiler und 20.000 verschiedene lebensnotwendige Hex-Editoren später startete dann auch mal das KDE - vollautomatisch!

    "Wow, Linux ist ja echt schon verdammt benutzerfreundlich!" dachte ich mir.
    Ein bisschen hier rumgeklickt, ein bisschen dort ausprobiert; was genau ich getan habe weiß ich nicht mehr. Nur irgendwann wollte ich eben auch die installierten Minispielchen ausprobieren.

    Jedes zweite krähte mich aber mit irgendwas in dieser Richtung an: "3D-OpenGL-Beschleuniger nicht aktiviert! 3D-OpenGL-Beschleuniger nicht aktiviert!"

    "Okay," dachte ich mir "Treiber muss man natürlich noch selber installieren."
    Mit ein wenig Hilfe eines Freundes kam ich auch drauf, wie ich die rpm-Dateien der ATI-Page ausführe. Reboot.

    Zack - KDE bootet nicht mehr!
    Nun gut, wär auch zu einfach gewesen.
    Mit ein wenig mehr Hilfe eines Freundes kam ich auf die Idee, die Installationsanweisungen der ATI-Page zu befolgen.
    Also, Sachen konfiguriert, Dinge erstellt. Reboot.

    Zack! - KDE bootet immer noch nicht!
    Nun ja, irgendwo wars ja klar, dass das nicht so einfach geht.
    Mit noch ein wenig mehr Hilfe eines Freundes bin ich dann auf diese Seite gestoßen worden: http://linux-club.de/viewtopic.php?t=15733
    Brav das ausgeführt, was der nette Geek mir da empfiehlt. Reboot.

    Zack! - Ich bin in KDE drin!
    Doch was ist nun? Eine Auflösung von 640x480? Sehr augenschonend in Verbindung mit der fitzeligen Schrift, insbesondere auf meinem TFT...

    Und nun kommen wir zu meinem Problem (neben der Tatsache, dass KDE nun doppelt so lang zum initialisieren braucht):

    Ich kann die verfluchte Auflösung nicht umstellen!
    - Ich habe es mit sax versucht
    - Ich habe es mit STRG+ALT+(+) versucht
    - Ich habe es über die blöde Treiberkonfig von ATI versucht

    Ich bekomm die verdammte Auflösung einfach nicht mehr höher.
    (Ach ja, und die 3D-Beschleunigung ist immer noch nicht aktiv)

    Hätte ich jetzt die Linux-CD hier, würde ich einfach das System komplett neu installieren, bin ich ja von Windows gewohnt.

    Wenn also einer eine Idee hat und/oder Lust hat, mir zu helfen...

    Dabei wollte ich doch nur Pingus spielen.


  2. #2
    Chawki
    Gast
    Da fehlen nur ein paar Modelines, die man selber anpassen kann:

    http://xtiming.sourceforge.net/cgi-bin/xtiming.pl
    http://koala.ilog.fr/cgi-bin/nph-colas-modelines

    Da muß man natürlich zusätzlich umrechnen, wenn man die Grakkarte übertaktet hat (durch Quarz-Tausch), und den Monitor nicht

  3. #3
    1337 gamestar-kiddie
    Gast
    poste mal die ausgaben von den befehlen:
    lsmod | egrep '(fglrx|radeon)'
    cat /var/log/XFree86.0.log | egrep '(EE|WW)'

    die meiner meinung nach beste installationsaleitung: http:http://www.gmpf.de/german/

  4. #4
    Benutzerbild von Baka
    Registriert seit
    Nov 2002
    Ort
    H zu dem i
    Beiträge
    3.846
    Likes
    0
    @nobody0:
    Habe die Config-Datei entziffern und öffnen können.
    Es sind bereits Modelines drin, die müssten so richtig sein.

    @Gronau:

    Der Wert für den ersten Befehl ist:
    fglrx 170984 0

    Beim zweiten spuckt er das aus:
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) Open APM failed (/dev/apm_bios) (No such device)
    (II) Loading extension MIT-SCREEN-SAVER
    (WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
    (WW) fglrx(0): Cannot read colourmap from VGA. Will restore with default
    (WW) fglrx(0): Kernel Module version does *not* match driver.
    (EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *
    Falsche Treiberverison für den Kernel, wie es aussieht.

    Ich lese atm diese Anleitung durch, scheint recht gut zu sein.
    Hoffentlich bekomm ich den Treiber auch wieder weg.

  5. #5
    Benutzerbild von Baka
    Registriert seit
    Nov 2002
    Ort
    H zu dem i
    Beiträge
    3.846
    Likes
    0
    *doppelpost*

    Kann sein, dass ich mich irre, aber ich krieche ja afaik mit dem 2.6.X Kernel rum. Also auf jeden Fall irgend etwas neueres.
    Aber ATI-Treiber existieren doch nur für die Version 2.4.X, oder?
    Dann kann ich ja de fakto überhaupt keine 3D Beschleunigung aktivieren derzeit? :/

  6. #6
    1337 gamestar-kiddie
    Gast
    Auch wenn die ati-treiber für 2.4 ausgelegt sind laufen die auch mit fast allen 2.6 zusammen, probleme gibts nur bei xorg > 6.8 und xfree 4.4. Suse9.0 hat afaik kernel 2.4 und xfree 4.3 deswegen dürfte es keine probleme geben.

  7. #7
    Benutzerbild von Baka
    Registriert seit
    Nov 2002
    Ort
    H zu dem i
    Beiträge
    3.846
    Likes
    0
    Original erstellt von Gronau
    Auch wenn die ati-treiber für 2.4 ausgelegt sind laufen die auch mit fast allen 2.6 zusammen, probleme gibts nur bei xorg > 6.8 und xfree 4.4. Suse9.0 hat afaik kernel 2.4 und xfree 4.3 deswegen dürfte es keine probleme geben.
    Naja, und woran liegt das hier dann?:


    (WW) fglrx(0): Kernel Module version does *not* match driver.
    (EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work

Forumregeln

  • Es ist dir nicht erlaubt, neue Themen zu verfassen.
  • Es ist dir nicht erlaubt, auf Beiträge zu antworten.
  • Es ist dir nicht erlaubt, Anhänge hochzuladen.
  • Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.
  •