Zeige Ergebnis 1 bis 8 von 8
  1. #1
    Benutzerbild von much
    Registriert seit
    Nov 2002
    Beiträge
    863
    Likes
    0
    Mein Eterm sieht momentan so aus:

    Code:
    #!/bin/sh
    Eterm -c white -0x --shade 0 \
    --scrollbar off --buttonbar 0 --trans \
    -f white -g=111x29+0+0 > /dev/null 2>&1
    Leider muss ich immer source .bashrc oder source .aliases oder bash ausführen, um meine aliase nutzen zu können.

    Denn diese Variante funktioniert leider nicht

    Code:
     #!/bin/sh
    Eterm -c white -0x --shade 0 \
    --scrollbar off --buttonbar 0 --trans \
    -f white -g=111x29+0+0 -e source .aliases > /dev/null 2>&1
    Was wohl an dem Leerzeichen zwischen source und .aliases liegt. Allerdings hab ich keine Idee, wie ich das anders machen soll, denn mit Backslash davor klappt es auch nicht.

    danke schonmal
    Linux is like a wigwam - no windows, no gates, apache inside


  2. #2
    Benutzerbild von sOuLjA
    Registriert seit
    Mär 2002
    Ort
    Hannover
    Beiträge
    8.340
    Steam Nick
    sOuLjA4eVeR
    Likes
    1
    hm also ich hab alle meine aliases in der /etc/profile drin stehen, das funzt wunderbar
    The box said, 'Requires Windows 95 or better', so i installed Linux

  3. #3
    Benutzerbild von much
    Registriert seit
    Nov 2002
    Beiträge
    863
    Likes
    0
    Funktioniert wunderbar.

    danke
    Linux is like a wigwam - no windows, no gates, apache inside

  4. #4
    Benutzerbild von Mithrandir
    Registriert seit
    Aug 2000
    Ort
    Aachen
    Beiträge
    3.986
    Likes
    0
    Damit sind deine Aliases jetzt systemweit verfügbar, auch für andere User (wenns nicht kritisch ist, ists ok, ansonsten aufpassen, jeder kann die aliases nutzen und lesen).

    Dein Problem hättest du durch ein paar Anführungszeichen lösen können afaik. Der Shell-Parser zerlegt den String in Argumente nach jedem Leerzeichen. Quote das mit " und du verhindest das Splitten: -e source .bashrc muss zu -e "source .bashrc" werden, dann sollte das gehen.
    [small]Viele Namen habe ich in vielen Ländern. Mithrandir heiße ich bei den Elben, Tharkûn bei den Zwergen;
    Olórin war ich in meiner Jugend im Westen, der vergessen ist, im Süden Incánus, im Norden Gandalf; in den Osten gehe ich nicht.


    J.R.R. Tolkien - The Lord Of The Rings[/small]

  5. #5
    edgewalker
    Gast
    -e source .bashrc funktioniert deswegen nicht, weil es kein Programm namens "source" gibt. Mit -e startest du irgendein Programm anstelle der Shell. Das Leerzeichen sollte kein Problem sein -- alle Terminalemulatoren die ich kenne fassen den kompletten Rest der Parameter als eine Kommandozeile auf, sobald sie ein -e sehen.

    Dein Problem liegt darin begründet, dass die .bashrc nur von Login-Shells ausgeführt wird (siehe man bash unter INVOCATION), und Eterm die Shell nicht als solche startet.

    Du kannst die Sachen statt in .bashrc in .profile schreiben, das von jeder Shell ausgeführt wird. Oder in .bash_profile, das nur von bash-Instanzen ausgeführt wird. Oder du kannst Eterm den Parameter -l übergeben, mit dem Eterm die Shell als Login-Shell startet; dann wird diese die .bashrc laden. Oder du schreibst source ~/.bashrc in die .bash_profile.

    Die letzte Variante würde ich bevorzugen.

  6. #6
    Benutzerbild von ap0calypse
    Registriert seit
    Jan 2004
    Ort
    Wörgl / Tirol / Austria
    Beiträge
    1.428
    Likes
    0
    Oder:

    Du führst aterm so aus:

    aterm -e bash --login

    So habe ich es gelöst ...
    To follow the path:
    look to the master,
    follow the master,
    walk with the master,
    see through the master,
    become the master.

  7. #7
    edgewalker
    Gast
    Stimmt, damit übergibst du der Bash den --login Parameter und forderst sie damit auf, sich als Login-Shell zu betrachten.

    ... Alle Wege führen nach Rom?

  8. #8
    Benutzerbild von ap0calypse
    Registriert seit
    Jan 2004
    Ort
    Wörgl / Tirol / Austria
    Beiträge
    1.428
    Likes
    0
    Original erstellt von edgewalker


    ... Alle Wege führen nach Rom?
    Stimmt
    To follow the path:
    look to the master,
    follow the master,
    walk with the master,
    see through the master,
    become the master.

Forumregeln

  • Es ist dir nicht erlaubt, neue Themen zu verfassen.
  • Es ist dir nicht erlaubt, auf Beiträge zu antworten.
  • Es ist dir nicht erlaubt, Anhänge hochzuladen.
  • Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.
  •