Zeige Ergebnis 1 bis 6 von 6
  1. #1
    Benutzerbild von ap0calypse
    Registriert seit
    Jan 2004
    Ort
    Wörgl / Tirol / Austria
    Beiträge
    1.428
    Likes
    0

    Kommunikation Windows-Telnet und Linux-Server-Applikation

    Mahlzeit,

    Ich schreibe derzeit eine kleine Serveranwendung in C, im Grunde eine Inventarisierungsgeschichte mit Datenbank dahinter usw.

    Worauf ich hinaus will:

    Mit Linux-Telnet via Terminal ist es kein Problem auf die Serverapplikation auf Port 23235 zuzugreifen. Ich schicke dem Server also eine Zeile Daten und fertig.

    Bei Windows hingegen ist es eigenartig. Ich connecte zum Server auf Port 23235 und will das gleiche tun, jedoch sofort nach dem ersten Zeichen bricht er die Verbindung ab. Das eine Zeichen wird jedoch übermittelt. Es ist beinahe so, als würde nach jedem Zeichen ein EOF oder so gesendet werden. Ich habe es schon auf mehreren Rechnern versucht. Meine erste Vermutung war, dass die Winsock schuld ist, aber da kenne ich mich leider zu wenig aus. Könnte mir da jemand einen guten Rat geben?

    Sorry, falls ich etwas nicht / zu ungenau erklärt habe. Ich habe ein wenig Zeitdruck
    To follow the path:
    look to the master,
    follow the master,
    walk with the master,
    see through the master,
    become the master.


  2. #2
    Benutzerbild von qq~
    Registriert seit
    Apr 2002
    Beiträge
    285
    Likes
    0
    Schonmal 'nen anderen Telnet Clienten probiert? :thumbsup:

  3. #3
    Benutzerbild von ap0calypse
    Registriert seit
    Jan 2004
    Ort
    Wörgl / Tirol / Austria
    Beiträge
    1.428
    Likes
    0
    hm nein

    Aber, ich bin zwar kein MS-Freund, eine simple Verbindung aufbauen zu können, darf man wohl auch von der telnet.exe verlangen oder?
    To follow the path:
    look to the master,
    follow the master,
    walk with the master,
    see through the master,
    become the master.

  4. #4
    Benutzerbild von ap0calypse
    Registriert seit
    Jan 2004
    Ort
    Wörgl / Tirol / Austria
    Beiträge
    1.428
    Likes
    0
    Ich habe es jetzt mal mit putty versucht und siehe da: Mit der Raw-Einstellung funktioniert es fehlerfrei. Ich würde trotzdem gerne wissen, warum es mit dem telnet-client unter Linux funktioniert aber unter Windows nicht.
    To follow the path:
    look to the master,
    follow the master,
    walk with the master,
    see through the master,
    become the master.

  5. #5
    Benutzerbild von Mithrandir
    Registriert seit
    Aug 2000
    Ort
    Aachen
    Beiträge
    3.986
    Likes
    0
    Schuß ins Blaue: Unicode? Windows sendet 2 Bytes pro Zeichen und das zweite Byte beendet die Verbindung, weils zufällig EOF ist oder was in der Art?
    [small]Viele Namen habe ich in vielen Ländern. Mithrandir heiße ich bei den Elben, Tharkûn bei den Zwergen;
    Olórin war ich in meiner Jugend im Westen, der vergessen ist, im Süden Incánus, im Norden Gandalf; in den Osten gehe ich nicht.


    J.R.R. Tolkien - The Lord Of The Rings[/small]

  6. #6
    Benutzerbild von ap0calypse
    Registriert seit
    Jan 2004
    Ort
    Wörgl / Tirol / Austria
    Beiträge
    1.428
    Likes
    0
    Damit könntest du ziemlich richtig liegen. Hmm ...
    To follow the path:
    look to the master,
    follow the master,
    walk with the master,
    see through the master,
    become the master.

Forumregeln

  • Es ist dir nicht erlaubt, neue Themen zu verfassen.
  • Es ist dir nicht erlaubt, auf Beiträge zu antworten.
  • Es ist dir nicht erlaubt, Anhänge hochzuladen.
  • Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.
  •